Home » » Firmware 2.2 download links

Firmware 2.2 download links

Written By Hans Berger on Saturday, November 22, 2008 | 6:24 AM

For those who want to upgrade to Firmware 2.2 without jailbreaking their iPhone or iPod Touch, I've posted the download links here.

Remember to update to firmware 2.2 all you need to do is:
1. Launch iTunes
2. Click update and choose your firmware 2.2 IPSW file
3. iTunes will take care of the rest! :)

If you want to restore to firmware 2.2 or another firmware all you need to do is:
1. Launch iTunes
2. Shift-click Restore for Windows users and option-click restore for Mac users
3. Choose your .IPSW file that you want to restore to
4. iTunes will do the rest!

Share this article :

+ comments + 204 comments

Anonymous
November 22, 2008 at 7:26 AM

Im an AT&T iPhone 3G user, i'm confuse because i don't neet to unlock my iPhone to use it with another carrier. My question is: If I update to 2.2 3G, using iTunes, will I be able to jailbreak my iphone later when the good people of the DevTeam release the pwntool 2.2 ?

Anonymous
November 22, 2008 at 8:49 AM

i can't downgrade back to 2.1 with my iphone 3g. it gives me an error(1012) at the end of restoring. any help?

Anonymous
November 22, 2008 at 2:17 PM

Any one know if this works for 2g ipod touch?????????

Carlos
November 22, 2008 at 2:55 PM

all i want is cydia, and instaler, how can i get them with the 2.2 firmware??

Sonny
November 22, 2008 at 5:53 PM

(Caution if you upgrade to iPhone 3G 2.2 you won't be able to unlock your iPhone 3G)
Who said this.. why? is there any unlock for 3G.. will never happen so what's the point???!!

Anonymous
November 22, 2008 at 7:27 PM

i've already updated my iphone 2g to 2.2 firmware using itunes! please help! i need to unlock it and jailbreak it! what do i do now? please reply to umair_nadeem@hotmail.com

Anonymous
November 23, 2008 at 2:04 AM

I downloaded it and uppon unzipping get a folder, not a file. I can't select this to upgrade from iTunes as the dialog shows open and opens the folder, but doesn't select anything. Any idea what is going on?

Anonymous
November 23, 2008 at 3:52 AM

I updated with Quickpwn and Cydia now has a NetDB error and none of the repositories will connect. Any insight?

Anonymous
November 23, 2008 at 4:26 AM

Whats new or beed updated in 2.2 compared to 2.1.1?

Admin
November 23, 2008 at 6:05 AM

I also would like to know what the difference between the two firmwares are.

Anonymous
November 23, 2008 at 10:04 AM

I have a 1st gen ipod touch and when i downloaded the firmware for it there were just a bunch of different files, not an ispw. I don't know whats going on. Can someone plz help me?

Anonymous
November 24, 2008 at 3:57 AM

To:Anonymous Says :
November 23, 2008 9:31 PM

I have the same problem, my CYDIA WONT DOWNLOAD ANYTHING!
What could I be doing wrong? I've tried QuickPwn and Pwnage and I get the same results.

try to check your network settings...

Anonymous
November 24, 2008 at 8:18 AM

This is not network related issue.
I had the same problem. couldn't download or install many apps like MxTube after upgraded to 2.2. I ended up downgraded to 2.1.

pramod
November 24, 2008 at 10:10 AM

the link to download the 1st gen ipod touch 2.2 firmware is broken...can u guys post a good and a workin link for the same...i would appreciate it if something can be done about it soon...

Anonymous
November 24, 2008 at 4:51 PM

same here i downloaded and did everything as i did before and my phone crashed had to restore! whats going on?????????

John
November 24, 2008 at 7:52 PM

I have a iphone 3g 2.1 jailbroken with qwkpwn. Cydia has never worked for me (it just crashes when launching) and non of the installaer apps have really made me happy, So now with firmware 2.2 offering podcast downloads, and Vodafone in NZ arn't allwed to lock the phones, the only feature I want is to use as a data router, but not super critical to me at this time. Can I simply do a normal iTunes upgrade to the 2.2 firmware and jailbreak again later if I want to or do I have to recover to a default 2.1 firmware first before upgrading?

Topzor
November 25, 2008 at 4:24 AM

Anyone updated the firmware without reading? I did, and I miss the part were 3G don't work. Ouch :(

Can we roll back to firmware 2.1 from 2.2? If so, can you help with a how-2 or a link?

thanks in advance.

Anonymous
November 25, 2008 at 1:18 PM

I unlocked the phone after upgrading to 2.2, but when I inserted a T-Mobile SIM card, it does not work.

Does anyone know what the problem is?

Anonymous
November 25, 2008 at 9:56 PM

I updated iphone 3g from i tunes to 2.2 (windows) and tried to jailbreak, now i can't restore, downgrade or anything... any suggestions?
ıf yes please mail

thanks in advance
kadir@dream-box.tv

Anonymous
November 26, 2008 at 4:30 AM

hey you kadir@dream-box.tv

to downgrade set to DFU mode,then restore with iTunes....before u update PLEASE read the limitations....my GOD its mention above...you know you guys if you fing out there's a new FW you just go through all the forums, browse and you know what you're looking JUST the download link of the latest FW!!! these guys who built and post some advice in this forums are helping you and giving some warnings but you don't know how to read...come on!!! it's mentioned how many times.

ps for those who downloaded .zip just change file extension to .ipsw OKAY!?!?!

dgmxviana
November 26, 2008 at 6:52 PM

***READ IMPORTANT***
if your using ANY TURBO SIM ADAPTER for the iphone 3G DO NOT UPDATE to 2.2 AT ALL, other wise the SIM ADAPTER WILL NOT WORK AND YOU WILL GET A TEXT SAYING NO SERVICE TOP LEFT OF THE IPHONE SCREEN......

**in case you updated already dont even bother downgrading to 2.0 or 2.1 or EVEN 1.1.3 (if thts possible i dunno) but even if u downgrade the sim adapter will not work so no unlcoking capability REASON IS BECAUSE AS SOON U CLICK UPDATE 2.2 IT WILL install a MODEM FIRMWARE 0.2.28.00 to check if you are fucked click SETTINGS> GENERAL> ABOUT, THEN navigate all the way down to "Modem Firmware"......

Jailbreaking will work but it wont unlock the phone what so ever

**Ziphone doesnt work to unlock or downgrade the baseband either so dont bother iven trying all possiblilites over 27 times still counting ( inlcudes downgrading jailbraking etc.)
there is a solution to the fix, which includes $$....theres this site saying you have to buy a sim adapter v3 it will be released this morning...i dont know what the fuck im doing up so late lol just updating my ipod touch 2nd gen lol anyway!

***mail me at dgmxviana@gmail.com to get the site
reason being cuz i dont want the siteto close down!!!!***

timm
November 27, 2008 at 1:07 AM

i cant find the IPSW to jailbreak my I pod touch v2.2! where i have to browse? thanx

Anonymous
November 27, 2008 at 7:22 AM

iPod2,1_2.2_5G77a_Restore.ipsw for ipod touch 2g
iPod1,1_2.2_5G77_Restore.ipsw for ipod touch 1g
try google them

Anonymous
November 27, 2008 at 8:45 AM

iPod Touch 1st Gen 2.2 download link dont work
:(

Anonymous
November 28, 2008 at 3:02 AM

it doesnt work for itouch 1g!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
='(='(='(='(='(='(:'(

culon008
November 28, 2008 at 3:43 PM

i got the firmware 2.2 on my pc and on 2nd step of quickpwn when it checking for the firmware, it said "error firmware string"?????????any1 know y and how to fix it????????plz help

Anonymous
November 28, 2008 at 4:33 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:34 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:35 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:37 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:38 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:39 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:40 PM

WTF 1st gen 2.2 download link wont work (403 forbidden error) and i cant find it any where else. pls fix quickpwn

Anonymous
November 28, 2008 at 4:52 PM

NVM guys found A link that has 1st gen 2.2 firmware download that works!!!!!!!!!!!!!!!


http://www.felixbruns.de/iPod/firmware/

Anonymous
November 29, 2008 at 3:22 AM

I have a 1st gen unlocked / jailbroken iPhone running 1.x firmware with a T-Mobile SIM. I'd like to upgrade to 2.x firmware. Can anyone point me in the right direction on how to do this? Do I first upgrade to 2.2 firmware, un-jailbreaking my phone, then re-break it? Or is there a way to upgrade the firmware without un-jailbreaking it?

Anonymous
November 29, 2008 at 6:43 PM

So...I have Iphone 3g and with ATT as my carrier...I can upgrade to 2.2 right and run quickpwn because I don't care about "unlocking" right because I'm already with ATT???

Anonymous
November 30, 2008 at 3:23 AM

When i try to download the 1st generation firmware link it gives me this error message.An error occurred while processing your request.

Reference #50.715d040.1228065609.557a7436

but i found a link that works

http://www.felixbruns.de/iPod/firmware/

Anonymous
November 30, 2008 at 3:29 AM

try this link

http://www.felixbruns.de/iPod/firmware/

iNano
November 30, 2008 at 7:51 AM

OMG!! iwas so nervous to "update"my iunlock iphone after buuyin it on ebay already unlock to 2.1 .. worked like acharm! THANK YOU QUICK PAWN!!!!!!!!

Anonymous
November 30, 2008 at 8:43 AM

i downloaded itand i have a .zip file so itunes doesnt recognize it! i tried changing the file extention to .ipsw but it stills doesnt recognize it!
what can i do please help!

Anonymous
December 1, 2008 at 9:06 AM

i have an ipod touch 2g.... is the jailbreak for it out yet? i cant seem to find it anywhere

Nick
December 1, 2008 at 10:13 AM

HELP

i went from 2.0.2 to 2.2 and upgraded to the newest version of itunes.

my phone works fine on t-mobile but everytime i try to connect it to ITUNES the phone cycles itself off.

it did it with both itunes 7.7 and the new version?

what do i do

MY AYM SN IS YABOYFABONICK someone help!

Anonymous
December 2, 2008 at 8:14 AM

when you select the .ipsw in quickpwn make sure you select the one you downloaded and not the one in the default folder and it should work fine

Anonymous
December 2, 2008 at 9:57 AM

if i update firmware 2.2 for ipod 2.2, anyway i can continue jailbreaking ?

Anonymous
December 2, 2008 at 3:16 PM

After downloading the firmware, I clicked on it and it only opens iTunes. My ipod is connected and all. And when I tried to open Quickpwn, it said I need to download the firmware which I did

Anonymous
December 2, 2008 at 6:42 PM

so many negative comments... so y in cydia some of the newest apps says it runs ONLY on 2.2...? quite contradicting...

michael
December 3, 2008 at 8:32 AM

i have an iphone 2g on 2.1 firmware i just want to make sure before i do this and upgrade to 2.2 but if i do this will it unlock my phone for a different sim card or will it just jailbreak it?
please help my email is
Osufanma@yahoo.com
thanks in advance

Anonymous
December 5, 2008 at 4:32 PM

soo this is for ituch 2g right?

Anonymous
December 7, 2008 at 3:11 AM

There are two download links for two different firmware files available for iPod Touch 1st generation here:
http://www.felixbruns.de/iPod/firmware/

And these are the two file names:
iPod1,1_2.2_5G77a_Restore.ipsw and
iPod1,1_2.2_5G77_Restore.ipsw

Do both of these work with quickpwn? Has anyone tested iPod1,1_2.2_5G77a_Restore.ipsw with quickpwn?

Anonymous
December 8, 2008 at 8:52 AM

i downloaded it what do i do after do i restore my itouch or what?

Anonymous
December 8, 2008 at 1:39 PM

will this unlock my iphone 2g
reply to anshulenator@gmail.com

Anonymous
December 8, 2008 at 7:15 PM

Does bluetooth for file sharing work with jailbreak edition?

Anonymous
December 9, 2008 at 4:58 AM

How do I jailbreak ipod 2g? Any guild?

Anonymous
December 9, 2008 at 9:50 AM

You cant get help from here to jailbreak your ipod 2g. devteam havent crack it yet. INFACT devteam has not even ipod "G to crack lol. will they try crach air lol.and anyway devteam gonna try linux for iphone so they are busy...

but podteam has jailbreak for ipod touch 2g
go that site

Anonymous
December 9, 2008 at 9:53 AM

there is NO iPod1,1_2.2_5G77a_Restore.ipsw
there is iPod2,1_2.2_5G77a_Restore.ipsw
and its for ipod 2generation

Anonymous
December 9, 2008 at 9:58 AM

they say if you udpate ipod 2G with 2.2 fw
you cant jailbreak it.
but that say devteam coz they havent jailbreak it. other group say other way :)

Anonymous
December 10, 2008 at 10:03 AM

Hello!

Can somebody help me? When I try to open firmware 2.2 for an iphone 2g, Quickpwn says that I am trying to open firmware 2.0.2...

The Iphone was updated to 2.2 with itunes and the official firmware.

Thanks!

Anonymous
December 10, 2008 at 10:41 PM

ive downloaded quickpwn 2.2 extracted it to my desktop and opened it i get an error! it does work! ive closed all apple related things i tried it on my mates computers and it wont work either! what am i doing wrong?!?!?!

Anonymous
December 11, 2008 at 4:07 AM

1st Gen Ipod Touch link doesn't work any more. Please fix.

Anonymous
December 11, 2008 at 6:03 AM

If i have the 2.0 firmware when i restore with the 2.2 firmware does it delete all my apps ive downloaded?

Anonymous
December 11, 2008 at 6:40 AM

I updated my iphone 3G to the 2.2 firmware using Itunes and I'm looking to jailbreak my phone. Do I select the link that says the iPhone or the Iphone 3G?

Btw, This isn't my first attempt. The first time I tried this, I selected the 3G firmware and when I ran quickpwn, everything was fine until the end when i had to reboot the phone. My phone just kept on continuosly rebooting and rebooting and rebooting...until it died. Until, recently I thought jalibreaking wouldn't come to mind, but w/e I'll try it again

ex
December 11, 2008 at 11:28 AM

ive been trying to find a solution. i upgraded to 2.2 firmware and when i load quickpwn it keeps stopping at the part where u put the phone in dfu mode. my phone is then stuck on restore mode where i have to restore it or else i cant do anything im going to try with out simcard but i cant go back to haveing regular phone hopefully someone can point me in the right direction

Anonymous
December 11, 2008 at 2:58 PM

does anyone's cydia work? i keep getting the NETdb error

Anonymous
December 12, 2008 at 5:23 PM

after custom quick pwn, restore everything. ---smooth running. want to update cydia, but everytime i open the cydia app, it just stop the UI interface where u choice the 3 menu, then it just turn off by itself.

Anyone can help to solve this

Anonymous
December 13, 2008 at 3:48 AM

I have tried everything to get my iphone 1st generation too unlock. I downgraded to 2.1 and used pwng tool. I also tried ziphone. I have apparently jailbroken my iphone, because i have cydia and installer on my phone. The problem is that when my T-Mobile sim is in the phone I cannot sync up to my iTunes. So I can have aphone or an ipod. Can somebody help

Anonymous
December 15, 2008 at 1:33 AM

Hey Guys ...

I have finally done it. If you guys are facing any problems with unlocking, do let me know my email is omar.arif@yahoo.com. It took around 12 hours for me to unlock it but I will let you know the procedure. catch ya all soon.

Cheers

Dogger
December 15, 2008 at 7:53 PM

Quickpwn 2.2 DOES not work any better than 2.1; In both cases I get to the point where it says "waiting for iphone to connect in recovery mode". In both cases nothing else happens. I am surprised that the developers did NOT fix this problem when upgrading quickpwn to address the 2.2 software update. Apparently lots of people have this problem but nobody can provide a solution that WORKS. I tried almost every suggestion that there is but nothing works. "WILL THE PROGRAM DEVELOPERS ACTUALLY LOOK AT THIS ISSUE OR CONTINUE TO IGNORE IT"!!!!!!!!!!!!

jithmatt
December 15, 2008 at 8:57 PM

Hi I hav an I-Touch 8GB model no A1288 well I vud love to jail break it ...its of version 2.2. I tried using Quick pawn but ver to locate the firmware bundle?? pls somebody help me on this

Anonymous
December 15, 2008 at 9:00 PM

Could someone please fix the link for the
iPod Touch 1st Gen 2.2 download?

Anonymous
December 16, 2008 at 6:32 AM

yeah it aint workin.
please help.

Arthur Gouveia
December 17, 2008 at 9:46 AM

I got my iPhone 3G and updated via iTunes to the 2.2 version. I didn´t knew that it was a problem.

Is still possible for me to jailbreak/unlock my iPhone? If yes, can someone tell me how?

I'm having a lot of troubles, including error on opening the quickpwn 2.2 =/

Anonymous
December 19, 2008 at 8:26 AM

HI, umm i have a i-touch second generation and is a 8gb, and i think it automatically updated the firmeware and now is 2.2 but i don't know how to jailbreak it, i already have the quickpwn program but it asked for the ispw file, and i dont have anyy idea wat they are talking about and i was wondereing if u can help, e-mail me ASAP at fiona808@hotmail.com

Anonymous
December 19, 2008 at 8:30 AM

ohhh ya my verson is 5g77a
e-mail me at fiona808@hotmail.com

Anonymous
December 21, 2008 at 8:34 AM

Hey guys, if anyone is still having problems JAILBREAKING or even UNLOCKING their iPod or iPhone on 2.2 give me an e-mail. mrwashboard@hotmail.com

As i have successfully unlocked the 3g 2.2 firmware with a Turbo Sim (it was 18 dollars free shipping on Ebay, and it took freaking 12 days for it to get to me...but it works!)

As for Jailbreaking, It works the EXACT same way as it did before, just make sure that you have the ipsw file in your itunes ipod or iphone update folder and it will automatically find your ipsw, or save it locally, like your desktop and browse for it. You download the ipsw's from here, OR if you have NOT upgraded to 2.2 through itunes then you can get a modified version of the ipsw from demonoid or your favorite torrent provider.

Other than that, if you have questions then e-mail me, as i will NOT be keeping an eye on this bulletin, so ANY comments to me MUST be e-mailed to me.

good luck, and happy hunting. (oh, and one more thing, with the new piggy back sims that are available, you can use the 3g option now!). peace!
V1x0r

Anonymous
December 21, 2008 at 10:47 AM

HI
I have a i-touch second generation and I updated the firmware and now is 2.2
In quickpwn it ask me for the correct ipsw
which my folder gives me iPod2,1_2.2_5G77a_Restore.ipsw
but quickpwn is saying firmware error string.
Cam anyone help me, I really want to jail break my i-touch
PLZ email me at darkrose0101@gmail.com
Thank you <3

Anonymous
December 22, 2008 at 3:22 AM

Ipod 2g 2.2

same ERROR like everyone

2nd step

"firmware error string"

what to do

please reply ASAP

Anonymous
December 24, 2008 at 4:06 AM

whats up peeps...

have a 3g 2.2 iphone that i want to use with a different carrier..

I tried quick pawn. everything installed correctly, but it does not recognize my sim card. I have read many conflicting documents and am looking for a few straight answers. Possible firmware problems? Please advise, thank you
tihspeed71@yahoo.com

Anonymous
December 24, 2008 at 7:08 AM

i would love to jailbreak my 3g iphone but for some reason i cant get it work everybody else can play with thier iphone i want to tooo!

Anonymous
December 25, 2008 at 3:33 PM

Can you jailbreak a 8G iPod Touch 2nd generation?

Anonymous
December 25, 2008 at 4:33 PM

Not Yet This sucks chronic dev is just releasing the iphone 3g jailbreak and now they say that they will not work on ipod touch 2g for the next 4 weeks so don't wait around !

Crazyivan
December 25, 2008 at 5:29 PM

That sucks, yeah I got my new iPod Touch for Christmas and I was looknig forward to getting some of those cools Apps, but I guess I will have to wait around. If I'm not mistaken, from what you said, by Feb. it should be possibl to jailbreak it?

tase
December 25, 2008 at 6:28 PM

Going to fork out the epic 4$ to get the apps I want then.
Jailbreak is nice if you want 10 apps or more, but it's simpler to just buy your app if you just want 1-2. Especially if it involves waiting 2 months.

FaTaLx45x
December 25, 2008 at 9:38 PM

HEY MOTHER FUKERS!!!! FIX THIS FUKING STRING ERROR SHIT THAT COMES UP WHEN I TRY TO UNLOCK MY FUKING IPOD!!!1

DO IT NOW U STUPID FUCKS!!!!!!

Anonymous
December 25, 2008 at 11:08 PM

wäre es nicht möglich anstelle eines Jailbreak 2g einfach einen Apple Server zu emulieren, der dem Ipod vorspielt das die Software original ist ?!

Anonymous
December 26, 2008 at 11:53 AM

when is the 2nd gen ipod touch jail break going to be out????

Pinocchio
December 26, 2008 at 6:06 PM

Please put your files on torrent, gnutella, eDonkey and etc and PLEASE put the CHECKSUM here.
I spent 2 day to download them from the websites, with no result.
I wanted to get them from the torrent network, but I was not sure if the files were the same.

Anonymous
December 27, 2008 at 4:44 AM

itouch 2g error string problem... when will be fix it!!! ,

Anonymous
December 27, 2008 at 9:22 AM

same we need a fix

Anonymous
December 28, 2008 at 7:54 PM

i tried jailbreaking my itouch 2g with 2.2 firmware and i cant make it past the second step once i browse for the firmware it says firmware error string can someone help me if so email me a soon as possible at billy_mcculley@hotmail.com

rio
December 29, 2008 at 2:57 AM

tried jailbreaking my itouch 2g with 2.2 firmware and i cant make it past the second step once i browse for the firmware it says firmware error string can someone help me if so email me a soon as possible at riom8a4@hotmail.com

Anonymous
December 29, 2008 at 3:34 AM

tried jailbreaking my itouch 2g with 2.2 firmware and i cant make it past the second step once i browse for the firmware it says firmware error string can someone help me if so email me a soon as possible at agzerr@yahoo.com

Anonymous
December 29, 2008 at 6:55 AM

HELP PLEASE Ive been trying to do this for 20 hrs straight im losing my mind its problem after problem so now my problem is that on the 4th step or so when u have to put ur touch in dfu mode but it never passes ''wait for your ipod to connect in recovery mode'' and it just hangs there why cant i pass it ive tried everything please help me

Anonymous
December 29, 2008 at 8:03 AM

as anyone succeeded jailbreaking a 2g with 2.2 firmware

Logun
December 29, 2008 at 11:09 AM

Edit: Is there anyone currently in the proccess of making a QuickPwn for the iPod touch 3g? If anyone has any info about that or the firmware for it please email me at

Logun147@gmail.com

Anonymous
December 30, 2008 at 6:15 AM

this shit doesn't work who ever made this website is a fucking dumbass that probly still lives with his mom and sleeps in the basement and is also a virgin so fuck you you computer nerd. i didn't try it but people are saying it doesnt work so i asum it doesnt work.

i am a 7 grader

Anonymous
December 30, 2008 at 11:21 AM

i have an ipod touch 2nd gen i try to unlock with quickpwn and i keep having an issue when i browse for this firmware it says error in firmware string....what am i doing wrong, im following the steps...i had no problem with my iphone when i jail broke it...Jcarlos521@netzero.com

Alex
December 30, 2008 at 2:28 PM

The program doesn't work with 2nd generation iPod touch yet. That's probably where the firmware error string problem is coming from. Just sit tight until a new solution is released I guess.

Anonymous
December 30, 2008 at 4:01 PM

wow that 7th grader needs to seriously get the crap kicked out of him, i mean seriously kid... grow a pair, get an education and then come out with a better program. Only then can you say that kind of stuff. Kids like you are need to learn to appreciate stuff

Anonymous
December 31, 2008 at 1:38 PM

No working link - iPod Touch 1st Gen 2.2 download

Error: An error occurred while processing your request.

Anonymous
January 1, 2009 at 2:23 PM

yeah the 1st gen itouch link isnt working
anyone have a mirror?

Anonymous
January 2, 2009 at 9:52 AM

hey, the 2nd gen 2.2 jailbreak doesn't work. not even with the itunes, nor the quickpwn 2.2. come on, is it just here to yank our balls, give a real jailbreak. it get's restored to normal firmware.

Anonymous
January 2, 2009 at 1:14 PM

"this shit doesn't work who ever made this website is a fucking dumbass that probly still lives with his mom and sleeps in the basement and is also a virgin so fuck you you computer nerd. i didn't try it but people are saying it doesnt work so i asum it doesnt work.

i am a 7 grader"

What a stupid post, I hope you never get your Itouch 2g to unlock. And to the Dev-Team. Thanks for all your hard work, we're all waiting patiently for a Itouch 2g unlock, so keep trying hard!

Anonymous
January 2, 2009 at 4:02 PM

It'd be nice if the first gen link was working. =\

Anonymous
January 2, 2009 at 8:48 PM

hello!
i download the link of quickpwn 22 but when i try to open it, it doesnt open!
can some one can show me how open the quickpwn??
thanks!

Pritesh
January 3, 2009 at 3:18 AM

I have a problem I downloaded 2.2 firmware for ipod gen2 iPod2,1_2.2_5G77a_Restore.ipsw and when used quickpwn 22-1 it said FIRMWARE ERROR STRING. and i can't jailbreak my ipod gen2 please reply ASAP to this email: pritesh061694@yahoo.com

Anonymous
January 3, 2009 at 3:49 AM

i have quickpwn2.exe and I have the correct firmware that matches my 2G ipod touch but when i get to the second step I browse for the ispw file, it starts to load but then stops and nothing pops up. any ideas?

Anonymous
January 3, 2009 at 10:03 AM

All the other links besides the 1st gen iTouch download. But, the one i need is the 1stgen iTouch. Whenever i click a link it says it requires me to logon and http 403 error, WHAT DO I DO?!?!?! plz help, thanks :D

Anonymous
January 3, 2009 at 10:04 AM

BTW i tried ^^^ on several computers.

Anonymous
January 4, 2009 at 3:00 PM

How do I get my I phone to get Cydia and Installer back If I updated my phone to to 2.2 on Itunes , because now It seem like my phone isn't unlocked or jailbroke but when I connect it to Quickpwn it says it has the ware already on device.
Help ASAP.

Cking
January 6, 2009 at 10:34 AM

QuickPWN still doesn't work on the 2nd generation (2G) iPod touch. I have the 32gb 2G ipod Touch with the 2.2 firmware, when can I expect the team to create a jailbreak??

Jay
January 7, 2009 at 5:47 AM

Hi, My names Jay

in need of help plz plz plz...
Whn im on the step where you choose the .ipsw file
after the first click on the blue arrow in quickpwn, i cant see the itouch 2g 2.2 picture and when i select the .ipsw file it will show a spinning circle and then just sit there and no blue arrow wont come up for the next step...

Help would be appreciated as im new to this....
thnxxxxxxx peeps

Anonymous
January 7, 2009 at 10:00 AM

i downloaded the ipod 2g 2.2 firmware and quickpwn22 and it doesnt work quickpwn goes to the plug in ipod detect screen and i click the arrow but when i get to the next page the image doesnt appear and when i click browse and choose the ipod2,1_2.2_5G77a_restore.ipsw file it comes up with firmware error string in red text plz help me make this work

David
January 7, 2009 at 10:25 AM

Please help i am having a serious error. When my phone reboots it gets stuck on the pineapple loading page. i tried to reboot it but itunes says it cant connect because it is locked with a passcode. It frequently vibrates, for some reason. I tried using quickpwn again but it said only firmware 2.2>or greater please help thanks.

Gilson Miranda
January 7, 2009 at 10:26 AM

Hi all,

When I upgraded my iphone 2G from firmare 1.1.4 to 2.2 thru itunes 8 on windows Vista 64bits or XP 32bits, The quickPWN can`t identify any firmware iphone1,1 2.2.....ipsw file

Error: firmware error string

I got tons of ipsw file versions, but neither works :(

What happened?

Davey
January 7, 2009 at 12:37 PM

i have a big problem, i download quickpwn, and when i click on the logo and click run it comes up and says "the application failed to intialize properly (0xc0000135). Click ok to terminate" WHAT DO I DO?!?!?!?!?!?!?! Please help

Thank you

Anonymous
January 8, 2009 at 1:34 AM

hey uhhh ya lol seams everyone els is having a problem as well, well heres what im getting: i download link everything works fine, it opens up i-tunes to my iphone and i have to shift+left click check for updates to select a folder to grab the firmware from. well i cant find the folder so i download a second file to my desktop and select it. it then go's threw everything it needs to for setting up my iphone for the update then it just stops and says error LEAVING my iphone in restore mode.meaning i have to completly restore my iphone to factory settings loosing all of my songs and pictures.

Jay
January 9, 2009 at 10:50 AM

Has sum1 cum up with the solution for "firmware string error" 2G 2.2 Itouch

plz plz plz help guyz

thnxxxxxxxxxxxxxxxx

Anonymous
January 10, 2009 at 5:43 AM

i have an ipod touch 2g, and im having trouble jailbreaking it. I downloaded quick pwn 2.2 and i downloaded the ipod firmware. When i open quick pwn, and i hit browse and select the firmware, it comes up with: "FIRMWARE STRING ERROR" i already have the 2.2 software, but quick pwn wont show my device on the screen!!

Any help?

Ed
January 10, 2009 at 9:10 AM

Anyone has the solution for "Firmware Error String" for the iPhone 3G using QuickPwn?

Anonymous
January 11, 2009 at 2:09 PM

I have a brand new IPhone 3g with firmware 2.2 already on it. How do I go about jailbreaking it? If anyone knows an answer please email me at MissingPhoenix5@aol.com or on here.

Anonymous
January 12, 2009 at 2:27 AM

didnt work for me. i've been stuck in a loop of restore to quickpwn to recovery for the past 12 hours. my phone as of now is pretty much useless. im gonna try to downgrade to 2.1 right now, 2.2 is lame anyways. MAKE AN UPDATE WITH LANDSCAPE TEXTING IF YOU'RE GONNA CAUSE ALL THIS TROUBLE!

Carlos Narvaez
January 14, 2009 at 1:04 AM

the link for the ipod touch 1st gen upgrade is broken. where else can i get it ? thx

Anonymous
January 14, 2009 at 3:11 PM

plz im having the same problem where i downloaded quickpwn but when i try to open all it says is "the application failed to intialize properly (0xc0000135). Click ok to terminate" i cannot get it to open and i tried to NOT extract it but its a self extracting file... help please!!!

Anonymous
January 15, 2009 at 1:33 AM

hey! I downloaded the firmware 2.2 for my itouch 2G but when i click the link for downloading the firmware 2.2 for my 1G itouch the window says Error 403 Forbidden.

Also with the QuickPwn, when i browse the 2.2 firmware that i downloaded for the 2g at the second step of the process for installing Cydia, it says " Firmware Error String"

Can anyone help me???
Please answer me to: motocross902@hotmail.com

Anonymous
January 15, 2009 at 6:50 AM

QuickPwn doesn't support iPod Touch 2G firmware version 2.2. It supports 1G though.

Anonymous
January 18, 2009 at 9:09 AM

How do you get it to work with Vista home, have everything loaded, but when i browse for my IPSW it can't locate. Please Help

Anonymous
January 20, 2009 at 11:42 AM

Every time i click on the link for th itouch 2.2 1st gen software the window wont take me there if someone could download that file and send it to me that would be awsome. stickman715@hotmail.com

masterJr
January 25, 2009 at 6:06 AM

okay, i heard ipod 2g can not be jail broken as of yet. if you have a ipod 2g go here: http://blog.iphone-dev.org/ and they will have updates. i also heard ipod 2g CAN be jail broke but i am having no luck finding it!

QuickPWN
January 25, 2009 at 6:12 AM

masterJr, you're right iPod Touch 2G can't be jailbroken yet! Only iPhone Dev Team blog is the official place to check for it. There are many places claiming to have it but they are fakes.

james
January 25, 2009 at 9:31 AM

how can u downgrade

justin
January 27, 2009 at 7:47 AM

I know. I need it too, but it says that there is an error.

michael
January 27, 2009 at 9:21 AM

i just updated today to 2.2.1 didnt think it would matter i have quick pwn 22-1 i get up to the 2nd part where it checks for firmware and i get firmware eror string i need help

QuickPWN
January 27, 2009 at 9:40 AM

It matters, QuickPWN does not support the new 2.2.1 firmware yet. The iPhone Dev Team is working on a jailbreak for it and I'll post it up here once it's released.

marshall
January 27, 2009 at 5:34 PM

is there a sure way to downgrade from the 2.2.1 firmware back to 2.2 as I am completely without a phone now lol.

Amir
January 27, 2009 at 11:58 PM

I have the 2.2.1 update now, and none of my apps work, i lost sbsettings. Once I quickpwn it again (when it is available) will it all work again? or will I have to re-install everything?? Change settings again, etc...

QuickPWN
January 28, 2009 at 12:05 AM

Once the iPhone Dev Team releases the new jailbreak software you will need to reinstall your jailbroken apps.

Dead Link
January 28, 2009 at 2:00 AM

hey guys the link for firmware 2.2 1st gen ipod is dead...cud u guys update it plz?

thanks

QuickPWN
January 28, 2009 at 2:37 AM

The link has been updated.

Pip
January 28, 2009 at 2:47 AM

Do you suggest holding off on the 2.2.1 update for 2G iphones?

sean
January 28, 2009 at 3:23 AM

ipod touch 1st gen 2.2 doesnt work pls fix

Shawn
January 28, 2009 at 3:26 AM

can you post a link for 2.2.1? I have problems downloading through iTunes. Thanks!

QuickPWN
January 28, 2009 at 4:21 AM

Go to http://www.quickpwn.com and you'll see a post with the link.

Steve C.
January 28, 2009 at 7:24 AM

how do i activate an iphone 2g, brand new OTB? i have tmobile, and it says i need to activate with a SIM with no PIN lock. could i possibly use an AT&T prepaid SIM card?

Raju
January 28, 2009 at 7:48 AM

Hello,
Trying to fix my iphone 1G.
The following combination does not work;
QuickPwn22-1.exe + iPhone1,1_2.2.1_5H11_Restore.ipsw
Error generated:
Firmware error string.

Any help would be greatly appreciated.

Thanks
Raju

QuickPWN
January 28, 2009 at 8:03 AM

Raju you're using the wrong firmware. Download firmware 2.2 from http://www.quickpwn.com/downloads.

Padro (required)
January 28, 2009 at 8:33 AM

I know ur probably getting tired of reading this but the Itouch 1g firmware download isnt working :S, I was checking on other sites and it said something about " It is now by version"... I didnt get it XD, but jst letting u know, could u plz update it 1 more time .

st3v3k3ll3r
January 28, 2009 at 8:39 AM

1st gen 2.2.1 itouch firmware error string when auto detects correct firmware. Help would be appreciated.

xxitachi
January 28, 2009 at 10:10 AM

do u know when this will be???

Matt
January 28, 2009 at 10:30 AM

The link for Ist gen 2.2 firmware isnt working again, can you plz fix it or post up an new link

QuickPWN
January 28, 2009 at 10:37 AM

The link has been updated now.

SAM
January 28, 2009 at 12:03 PM

If I try to download the 1G 2.2 FW .. I get a ZIP file and there is no FW inside!! is this normal .. or is there something wrong with the link

QuickPWN
January 28, 2009 at 12:13 PM

Just rename the .zip to .ipsw

Avi
January 28, 2009 at 12:21 PM

When do you expect the 2.2.1 jailbreak will be ready?

MiszBeauty
January 28, 2009 at 12:21 PM

When i tried to update my itouch with firmware 1g 2.2.1 after its dont it says there was an error....PLEASE HELP!

SAM
January 28, 2009 at 12:58 PM

ok.. I was able to update the 1G to the 2.2 FW... is there a way to jailbreak it ? or we cannot jailbreak the V2.2?

Matthew
January 28, 2009 at 2:19 PM

Yea just happened to me today as well. Well My jailbreak was going great until "kate" took over and I could not place calls, the application just keep crashing. I tryed everything from ssh to restarting. SO... I restored the phone and then restored back to what I had on 2.2. I missing applications, but noticed that my firmware had changed.

PLEASE DEV TEAM FIX THIS PROBLEM......

ANON
January 28, 2009 at 11:32 PM

where is the 2.2 firmware for 1st gen itouch? the link is for 2.2.1.

Francisco
January 29, 2009 at 4:43 PM

Hey.. I didnt know and i upgraded, now my iphone is lockedd.. i dont know what to do!!!

iphonic
January 29, 2009 at 6:26 PM

This does not seem to work for the 3G 2.2.1 firmware. If you already have the iPhone 3G with 2.2.1 firmware, you will most likely not be able to downgrade it to any of the previous firmwares...
If someone has the 2.2.1 on their 3G and was successful in downgrading to 2.2 or any other version of firmware, please let us know by posting on this page!!!

pie
January 30, 2009 at 4:58 AM

thanks my ipod touch 2.2 2en is jailbroken

brad
January 30, 2009 at 5:00 PM

looks like I am a few days late, got my itouch used with 1.1.5

upgraded to 2.2.1 (thought it was the same as 2.2) and it won't jailbreak.....crrapppp

John
January 30, 2009 at 7:02 PM

When u get the answer please tell me.

De§ire
January 30, 2009 at 10:31 PM

The iTouch 1G 2.2.1 link isn't working

Aubrey
January 31, 2009 at 2:28 AM

Your Mei was wondering is it possible to downgrade you iphone 3g to version 2.2?? help anyone just send me an email at sonny98982003@yahoo.com

ben
January 31, 2009 at 12:41 PM

I have an iPhone 3G. After many struggles, managed to downgrade from 2.2.1 to 2.2. But the baseband remained 02.30.03. I used the QuickPWN2-2-1 (windows version) for the jailbreaking. Then my mac for the rest...

lee
January 31, 2009 at 6:27 PM

hi, i wonder is all the comment and the firmware available here is only applicable for 3G phone only?
is 2G phone also can upgrade to firmware 2.2?

scannell13
February 1, 2009 at 1:20 AM

i have the same exact problem with my iPhone 3G!!!!! Some one please help!!!!!

EricT
February 1, 2009 at 3:52 AM

The itouch 1st gen link is broken.

walter
February 1, 2009 at 7:58 AM

Firmware error string for 3g iphone help me with this message

February 2, 2009 at 5:58 AM

why i can't find 2.2 firmware for iPod touch 1g ?
and now i can't downgrade my 2.2.1 to 2.2

Tim
February 4, 2009 at 4:33 AM

Can you PLEASE put the download link for iPod Touch 1st Gen
2.2(!) back on?
Not 2.2.1, just 2.2, cause the newest up here doesn't work well on my quickpwn!
Please!

blah
February 4, 2009 at 9:55 AM

I can't get itunes away from the "welcome to your new iphone" screen. I can't get to the restore option. So annoying. Pwnage doesn't seem to be doing anything, whether I try to use 2.2 or 2.2.1

tiernito
February 4, 2009 at 10:31 PM

i have quickpwn to unlock up to 2.2
anyone with information to unlock the 1 Gen.,(original)iphone on
firmware 2.2.1

Kasey
February 6, 2009 at 8:52 AM

I downloaded quickpwn and i downloaded the filmware above to jailbreak my ipod touch 2g 2.2 and when i browse the filmware it says "filmware error string" can anyone help?

Peter
February 6, 2009 at 8:09 PM

I download the firmware, but it asked me for a password to open it up? what do I do?

tony
February 6, 2009 at 8:18 PM

hi there.... the link for the 1st gen 2.2.1 itouch isnt working..... is it bust for good???

somebody fix it please?

Bejoy
February 7, 2009 at 6:10 AM

I have a question. I have the iPod Touch 2G and I have firmware 2.2.1. I want to downgrade to 2.2. I have the firmware and I put the iPod into DFU mode. I pressed Shift+Restore in iTunes and selected my firmware. The problem is, I got this error message:
The iPod "iPod" could not be restored. An unknown error occurred (1).
What should I do?

Hamilton
February 8, 2009 at 3:07 AM

I've a problem with the last version of quickpwn when I execute it, a message said: " error ...(0xc0000135)".
I've Windows Xp SP2 and Itouch 8G 1Gen.
Thank You!

Andrew
February 8, 2009 at 5:48 AM

whenever i try to jailbreak my itouch 2nd gen i always get up to the part that requires the create restore file and the file never appears....HELP PLZ

harry
February 9, 2009 at 7:01 AM

i have an ipod touch 1G and i want to download the firmware 2.2, not 2.2.1 because my ipod has 2.2 and if i try to jailbreak with the 2.2.1 it says that its the wrong firmware. What do i do?

pawan
February 9, 2009 at 6:28 PM

I’ve a problem with the last version of quickpwn when I execute it, a message said: ” error …(0xc0000135)”.

install .net framework 2.0 to solve this issue (google for .net)

Rahul
February 9, 2009 at 9:22 PM

The link for ipod touch 1st gen 2.2.1 is not working. Please help. I have a ipod touch with 1.1.3 firmware. How do I upgrade it to latest version and also jailbreak it. Is it possible?

oki
February 12, 2009 at 12:23 AM

you have to install NET framework...download it from windows.com

huhh
February 12, 2009 at 10:57 AM

If i download the 2.2 will it change the baseband to 2.28.00 beacuse i have 2.1 i cant unlock it with that baseband

Pela
February 13, 2009 at 4:55 AM

I tried downgrade the firmware to 2.2 to QuickPwn, but I coudn´t. I got an error number 1013 and be forced to instal 2.2.1. HELP ???

timestillnuh
February 13, 2009 at 4:55 PM

If u are on firmware 2.2, u cannot jailbreak straight to 2.2.1. u have to download quickpawn2.2, there is the link http://www.zshare.net/download/517212...

Bebop
February 14, 2009 at 2:06 PM

I have the iPhone 3G and I have firmware 2.2.1. I want to downgrade to 2.2. I have the firmware. I pressed Shift+Restore in iTunes and selected my firmware. The problem is, I got this error message:
The iPod “iPod” could not be restored. An unknown error occurred (1).
What should I do?

fadiman
February 15, 2009 at 2:00 PM

i pressed the option key on the mac but i dont know how toget the ipsw file

yusuf
February 15, 2009 at 3:30 PM

if you getting error in ipod even you connected iphone 3g simply dissconect and reconnet it its normal then you will get iphone 3g in itunes back,

derk
February 15, 2009 at 10:09 PM

I have the same issue, i want to downgrade to 2.2 but dont know how to get 2.2 on my computer? all i can find is 2.2.1.. do you know where i can get just 2.2?

Nimrod
February 16, 2009 at 2:34 AM

It's happan for me as well !
What should we do?

eap168
February 16, 2009 at 6:21 PM

Hi.... i have the G2 ipodtouch and with 2.2.1 firmware, i got lots of problem with the games with this firmware.. so, i download v2.2 from this site to downgrade my firmware to 2.2, when everything is done, i cannot connect anymore to wifi even i already configured it already. what do you want me to do to be able to use again my wifi. it can detect my wifi access and the check is ok.. but there is no antenna or wave sign on the upper left most besides ipod name. even its say its connected. can anyone help me on this. i tried to update my firmware again to 2.2.1 coz i thought maybe its because of the v2.2 firmware but its still the same... help plz. thanx

Darren
February 17, 2009 at 7:26 AM

Got the same problem as Jay..

I open quickpwnn and its asking to browse for firmware..
I have another 3g iphone which is on 2.1 but my new one is 2.2 so its only offering me the option to resstore which is no good...

richie
February 17, 2009 at 11:45 AM

what does it mean when it says "firmware error string"?

QuickPWN
February 18, 2009 at 4:35 AM

It means you didn't download the correct firmware or you are using iPod Touch 2G firmware which is unsupported.

asshole
February 18, 2009 at 4:43 AM

you should just wait till yellowsnow can unlock 2.2.1 if not just buy a damn turbosim its the same shit

Chrys
February 18, 2009 at 1:47 PM

My ipod touch screen will not pick up on my computer. it say apple camera. The only thing showing on the ipod screen is a picture of the itunes icon and an arrow pointing to the usb cord.

February 18, 2009 at 6:42 PM

i get the iphone iphone could not be restored. an unknown error occured (9) when i try to downgrade to firmware 2.2 form 2.2.1
can anyone help please

QuickPWN
February 19, 2009 at 7:46 AM

Follow the instructions here to downgrade. If you're stuck with anything post you question in the forums.

QuickPWN
February 19, 2009 at 7:55 AM

Hold down the square home button and the standby button until your iPod Touch turrns off. Then turn it back on by pressing the standby button.

Post a Comment

 
Copyright © 2012. QuickPWN - All Rights Reserved.